Choose fontsize:
Welcome, Guest. Please login or register.
 
Pages: [1]   Go Down
  Print  
Author Topic: Canon routine servicing and potential problem...  (Read 334 times)
0 Members and 1 Guest are viewing this topic.
Mike Margolis
AzAP Contributor - 250 Posts
**
Offline Offline

Posts: 350



View Profile Email
« on: May 29, 2017, 07:28:10 PM »

Any advice on the following would be greatly appreciated! Thanks in advance!!

First off, when (after how much usage/time) and where (local or send it off) do folks get their cameras/lenses routinely serviced? And how about repaired?

And second, I have been getting an error message about once every ten on/off cycles that says - "Sensor cleaning could not be performed. Turn the camera off and on again."

After turning it off (count to ten) and back on again, it works fine with no error message. But I do not want to end up with it "stuck" and not working...

Yes, I turned off automatic sensor cleaning for now. Anyone else get this message? The interweb says send it in to Canon...

~ 7DMkII with the 100-400MkII attached ~
Logged

"Could be worse... Could be raining."
Chris Janes
AzAP Contributor - 250 Posts
**
Offline Offline

Posts: 420



View Profile WWW
« Reply #1 on: May 29, 2017, 09:43:06 PM »

I've sent my 7D in for repair after I got into a hurry and put the cf card in backwards and bent the pins. I've also sent my 100-400 for a cleaning and tune up. Both were sent to the canon service center in Irvine, Ca. I had the camera and lens back in a week. No problems what so ever.  I sent the lens in after having it about six years. It actually came back better and sharper then when I first bought it.
Logged
Mike Margolis
AzAP Contributor - 250 Posts
**
Offline Offline

Posts: 350



View Profile Email
« Reply #2 on: June 02, 2017, 04:55:39 AM »

Thanks Chris!!
Logged

"Could be worse... Could be raining."
Pages: [1]   Go Up
  Print  
 
Jump to:  

TinyPortal v1.0 beta 4 © Bloc
Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
BlueSkies design by Bloc | XHTML | CSS